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Link: http://ecommerce.aheadworks.com/magento-extensions/store-credit-and-refund.htmi

Store Credit And Refund Magento extension introduces store credit functionality that allows creating, editing and
managing customer credit balance from the admin panel.

Installation

1. Backup your web directory and store database.
Click to view details

You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

&1 Backups

Fage 1 of 1 pages | View |20 v« | perpage | Tofal 0 records found h.ﬁ, o ‘h"l'i
Select All | Unselect Al | Select Visible | Unselect Visible | 0 items selected Actions v E

2. Log in to the Magento backend.

3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.
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& Compilation

Compiler Status
Compilation State

Collected Files Count

Compilation State

Compiled

7505

IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you
use "Run Compilation Process" function, not just "Enable button"

& Compilation

Compilation State
Disabled

Compilation State Compiled

Compiler Status

Collected Files Count 7505

Installing an extension with the Compilation enabled will result in store downtime.

4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

* via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

Cache Storage Management

Blocks HTML output

Page blocks HTML.

Select All | Unselect Al | Select Visible | Unselect Visible | 0 items selected Actinnslm
Cache Type Description Associated Tags Status
[ Configuration System(configxml, local xml) and modules configuration CONFIG
files(config.xml).
[J  Layouts Layout building instructions. LAYOUT_GENERAL_CACHE_TAG ENABLED
—

BLOCK_HTML

» via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

5. Download the extension package from your account and extract the downloaded archive.

6. Copy the content of /Step_1/ folder to your store's root directory.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current
theme's folders. In case there are several themes in use at the same store, the design files must be
copied to each of them.

+ Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
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» Find this folder in the package: /step_ 1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

7. Copy the content of /Step_2/ folder to your store's root directory.

8. Flush store cache again; log out from the backend and log in again.

Zero Checkout

Providing you want to let your customers to checkout
solely with store credit (paying for the whole order with
credit) the Zero Subtotal Checkout should be enabled.

To enable Zero Subtotal Checkout navigate to your
Magento backend System > Configuration > Sales>
Payment Methods > Zero Subtotal Checkout and set
'‘Enabled' field to 'Yes'.

Now your customer can checkout with store credit solely.

Configuration

The extension's configuration page is located at System -> Configuration -> aheadWorks Extensions -> Store
Credit and Refund. The same page can be accessed via Sales -> Store Credit -> Settings.

General Settings tab:

Enable Module - activates /de-activates the
extension.

Refund to Store Credit automatically - defines
whether the Store Credit will be a default refund
method or not.

How does it work?

This option defines whether the Refund
to Store Credit checkbox will be on by
default, or a store admin will need to tick
it manually each time a credit memo is
issued.

Append Comments

Email Copy of Credit Memao

Refund to Store Credit [« 30345

: .

Display 'Store Credit' in top links - shows / hides
the link to the Store Credit account page in the
header menu.

Display customer Store Credit Balance in top
links - works in conjunction with the option above;
shows / hides the current balance.

How does it look like?

confluence.aheadworks.com/display/EUDOC/Store+Credit+and+Refund

Title MNao Payment Information Required [STORE VIEW]
Enabled Yes =l S

New Order Status Pending = EBSITE
Payment from Applicable All Allowed Countries | EBSITE
Countries

Payment from Specific Countries Afghanistan i’ EBSITE

Enable Module

Refund to Store Credit
automatically

Display 'Store Credit'in top links

Display customer Store Credit
Balance in top links

CMS Page in Customer Area

Yes v
Yes v
The option defines the default Credit Memo behavior
Yes v
Yes v
—Please Select— v

Redirects a customer to this CMS page when clicking
on the 'Question’ icon

[WEBSITE]

[GLOBAL]

[STORE VIEW]

[STORE VIEW]

[STORE VIEW]
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Here's how the Top Links record look
like with the balance display enabled:

Welcome, Mariko Huffstutler!

My Account | Store Cres §8) | My Wishlist | My Cart | Checkout | Log Qut

¢+ CMS Page in Customer Area - sets the destination
page for the "learn more" link in the customer
account.

How does it look like?

The question icon in the customer's
account is a clickable link, that will
redirect a customer to the designated

page.

Balance

Your current balance is: 55,00 $US 9 ¢

Email Notifications tab:

 Subscribe customers automatically - defines
whether a customer will be automatically subscribed Subscribe customers Ves v messTe
to balance update notices the first time they receive MELEREL)
Store Credlt. S e NE“ links in the email will log a customer in! ! e
+ Enable automatic logging in - defines whether . T
. . . . anding Page [STORE VIEV
f0||0W|ng the links from the Update notices will |Og a Related to webstte URL, &.g. "phones/samsungl”. The

customer will be browsed to this page after clicking on

customer in to their account.

+ Landing Page - sets the destination page for all the
store backlinks in the module's notifications. If left
empty, the default destination will be the Home
page.

+ Email Sender - defines the Sender for the
extension's emails.

« Balance update template -allows selecting the
notification email template.

the ‘come back’ link in the email

Email Sender General Contact v [STORE VIEW]

Balance update template AW_Storecredit Email Template (Default Temp ¥ [STORE VIEW]

Managing Store Credit

The extension allows tracking and managing the store balance through 2 dedicated grids: Customers and
Transactions.

Tracking Customers

To view the list of all the clients who have ever had a positive credit balance at your store, navigate to the Sales ->
Store Credit -> Customers grid. This Grid shows the customer info (Name, Email, Group, etc) and extension-specific
values: Total Credit Earned, Total Credit Spent, Current Balance and Subscription Status.

Through this grid, you can change customers' subscription status as a mass action.
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Customers

Page of 1 pages | View

Select Al | Unselect Al | Select e | Unselec blz | 0 items selected

Customer ID Name Email
Any v From:
To:

3 | Mariko MarikoHuffstutier@example.com

TrevaGatlow@example.com

DebroahBookmiller@example.com

20 v perpage | Total 3 records found

Group

General

General

General

Country

AlCo v

United
States
United
States
United
States

Customer Since

From: |7

To: [

May 21,2013 1:08:19
AM

May 21,2013 1:08:20
Al

May 21,2013 1:08:20
AM

Last Visit
From: 3|
To: =

Nov 11, 2014 4:36:01
AM

= Exportto:[csv

Total Credit Eamned

From: From:
To: To:
$1,124.97
$10.00
$10.00

Total Credit Spent

fal For | (I —
Actions v :
Current Balance Balance Update Subscription
From: v
To:
$1,059.99 $64.98 Subscribed
$0.00 $10.00 Subscribed
$0.00 $10.00 Subscribed

Tracking Transactions

To view all the transactions that involved store credit, navigate to the grid located at Sales -> Store Credit ->

Transactions.

Transaction Types:

Created - reflects the initial action when a customer earns some store credit for the 1st time.
Modified - reflects one of the following events: a balance is changed by the store admin.

Used - reflects customer's spending any part of their available balance on an order.
Refunded - reflects a balance update after an admin issues a refund to the store credit.

Transactions
Page of 1 pages | View |20 w  perpage | Total & records found
D Name Email | Date
From: 5|
To: |5
8 MarikoHuffstutler@example.com Nov 11,20
7 MarikoHuffstutler@example.com Nov 11,20
6 er DebroahBookmiller@example.com Nov 11, 20
5 TrevaCatlow@example.com Nov 11,20
4 MarikoHuffstutler@example.com Nov 11,20
3 MarikoHuffstutler@example.com  Nov 11, 201
2 MarikoHuffstutler@example.com  Nov 11,20
1 MarikoHuffstutler@example.com  Nov 11,20

14 5:30:18 AM
14 4:35:05 AM
14 4:35:.04 AM
14 4:35:03 AM
14 43312 AM

447475 AM
14 1:42:23 AM
14 13757 AM

1 Action

Used
Modified
Created
Created
Refunded

Modified
Used
Created

5 Exportto:[cgv

Balance Change Balance
From:

To:

From:
To:

In:

540499

$404.99
-5404 .99

570095

(ll| Exvort | |

usb -

$64.08
$1,124.97
$10.00
$10.00
5111497

§709.98
$304.99
§709.98

Additional information

Added by admin: Reward for good reviews.
Added by admin: Reward for good reviews.

Added by admin: Reward for good reviews.

Crder refunded #
Credit Memo

Crder canceled #
Spenton order #

Order refunded #
Credit Memo 210

Adding / Modifying Customer Balance

The extension offers several ways for a store admin to update the customer's account. It is possible to make an
update individually for exact customer and/or perform mass actions.

Via Edit Customer screen

To track and update customer's current balance, use the dedicated Store Credit tab added to the backend Customer

View page.

To update a balance:

1. Enter the desired value in the Update Store Credit filed (entering a negative value will subtract from the

balance).

2. If necessary, supply the Comment in the field below (NOTE, the comment is visible to customer).

3. Save customer account.
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Store Credit Balance

Current Balance: $64.98

Subscribed to Balance Update? [+

Update Store Credit Balance

Update Store Credit |

& Enter a negative number to subtract from balanc e

Comment |

Store Credit History
Page |1 of 1 pages | View |2D v | perpage | Total & records found m
Balance Balance Change Action Additional information | Date i

From: | From: | [ v | From: .| li
To: | To: To: [&] li
In: |USD ¥ | In: UsD »

56498 -51,050.99 Used Spent on order #100000018. Mov 11, 2014 5:30:18
AM

Via Mass Action

To perform mass balance updates, use the Transactions grid:

1. Click Add New button.

2. After a page redirect, specify the update amount in the Store Credit Balance Change field (entering a
negative value will subtract from the balance).

3. Supply the Comment in the with the field below.

4. Select the necessary customer accounts from the list.

5. Click Save Transaction.
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Add Transaction «' Back

Fields

Store Credit Balance Change * |

Enter a negative number to subtract from the balance

Camment* |

“isible to customer

Page 1 of 1 pages | View [20 v | perpage | Total 7 records found wm

Select Al | Unselect Al | SelectVisible | Unselect \isible
| 0items selected
Customer ID Name Emiail Group Country Customer Since
Any v | From: | | v |AllCo v | | From: 3]
To: To: [&]
] 2 James customer.aw1@tut.by General United Aug 11,2011 5:5(
Stivensson States P
3 customer.aw2@iut.by General Izrael Aug 11, 2011 5:5(

Integration with other AW modules

The Store Credit and Refund extension integration with other aheadWorks products enables extra functionality:

+ One Step Checkout - if you are using One Step Checkout, the "Apply Store Credit" option will be displayed
under the Coupon Code field.

Grand Total $154.99

Coupon Code

[ | Use Store Credit ($54.98 available)

Camments

Uninstallation

If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.

+ Disable compilation, in case it is enabled.
« Login to your FTP, navigate to app/etc/modules/
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+ Open the file AW_Storecredit.xml and change the following line:

<active>true</active>

to

<active>false</active>

Now your Magento is unaware of the existence of this module.

Clear the cache under var/cache

Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
If everything works fine, it is safe to delete the files of the extension.

In case you need to clean the database, backup your database and then run the following queries in MySQL:

It is necessary to run the queries in the specified order

DROP

DROP
DROP
DROP
DROP
DROP

TABLE

TABLE
TABLE
TABLE
TABLE
TABLE

IF EXISTS "aw_storecredit_history_additional_info";

IF
IF
IF
IF
IF

EXISTS
EXISTS
EXISTS
EXISTS
EXISTS

“aw_storecredit_history;
“aw_storecredit_creditmemo_totals’;
“aw_storecredit_invoice_totals’;
“aw_storecredit_order_refunded_totals’;
“aw_storecredit_quote_totals’;

delete from core_resource where code ='aw_storecredit_setup';

Note, if you are using the table with prefixes, you must specify them in all table names.

If you are not sure how to do that or expect any troubles with it, please contact your server administrator

regarding the matter.

If you remove the tables as it is described above, you will need to set up the extension again after it is
reinstalled. All transactions history will be lost as well.

Troubleshooting

After the extension installation the store gives an error, or blank page, or suggests to start Magento
installation procedure.

Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.

After the extension installation | receive 404 error in System->Configuration->Store Credit and Refund.

Logout from backend and login back again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get
a blank page, or Access Denied error.

Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing on that page.
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Clear the store cache, clear your browser cache and domain cookies and refresh the page.
My configuration changes do not appear on the store.

Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com
License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt
Contact us: http://ecommerce.aheadworks.com/contacts/
Copyright © 2019 aheadWorks http://www.aheadworks.com
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