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Extension Page: http://ecommerce.aheadworks.com/shop-by-brand.html

Create brands, display brands menu, customize brands pages, and connect products to them.

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you
use "Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current
theme's folders. In case there are several themes in use at the same store, the design files must be
copied to each of them.

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/
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Configuration

General Configuration
General | Brands List Setup | Product Page Setup | All Brands Page Setup | Auto Generate

General extension settings can be specified in Catalog → Shop By Brand → Settings (or System →
Configuration → aheadWorks Extensions → Shop By Brand) backend page

 

General tab

Add to the menu: Yes/No - this option
defines if the link to the Brands Page will be
added to the Categories Navigation menu.

 

 

Brands List Setup

 Brands List is a block similar to layered navigation.
By default it is added into left column. 

Display mode - This option determines how
the navigation block 'Shop By Brand' will be
displayed 

 

 

Product Page Setup

 The extension can add a small logo and of name of
brand on product pages, below the price. 

Display mode - Select an option how brand
will be displayed on product page.

 

 

All Brands Page Setup

 

URL key - An URL where your page will be
available. 'brands' by default. Allowed
characters: letters (a-z), numbers (0-9),
dash( - ) or underscore(_).

Title - The title which will appear in Top menu
and in All Brands page
Meta Keywords, Meta Description - the
options to define Meta keywords and
description respectively.
All brands page description - WYSIWYG /
HTML editor. Will be displayed under the
brands list. 

 

 

Auto Generate

 

For Magento CE 1.8+ users
The URL key must contain lower case
characters only
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Since version 1.4.0 brand autogeneration option has
been implemented.

By selecting required product attribute and clicking
Generate button new Brands are created according
to the attribute values.

 

 

 

 

Brands setup

How does Brand autogeneration work?
1) Auto Generate option works only for the
attributes with 'Catalog Input Type for Store
Owner' - Dropdown;

2) EACH Attribute Option should has at least
one product associated with it for Brand to be
created:

For example:

We have the Attribute
Manufacturer with Catalog Input
Type for Store Owner - Dropdown;
Manufacturer attribute has three
options: Apple, Nokia, Samsung;
Apple and Nokia options each
have a product associated with
them: iPhone and Nokia Lumia
respectively;
Samsung option doesn't have a
product associated with it.

If we decide to Auto Generate
brands for Manufacturer attribute
we will get the following results:

a) For Attribute Options Apple and
Nokia we will have corresponding
Brands generated;

b) For Attribute Option Samsung no
Brand will be generated as no
products have been associated with
it.

Note: after Brand Auto Generation
ALL products associated with the
Attribute Options will be respectively
associated with the Brands
generated.

3) If Brand with the same name as Attribute
Option already exsists it will be
OVERWRITTEN with the new values;

4) Newly generated Brands are Not Active by
default.
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General | Images | Products | Brand Page

 
Brands can be managed through Catalog → Shop By Brand → Manage Brands backend page. To create a
new Brand, click Add New button.
 

General tab:

Title - the Brand name, will be used in the
frontend
Status - enables / disables the Brand
Show in Sidebar - includes to / excludes from
the sidebar brands navigation block
Priority - defines the Brand position in the list.
Brands with higher priority will be displayed first. 

 

Images tab:

Through this tab, you can upload Brand Icon and
Brand Image.

Brand Icon will be displayed on the sidebar
brand navigation block and on the product pages.
The default icon dimensions are 50x50 px
Brand Image will be displayed on 'All Brands'
page and on the dedicated page of this brand.
The default image dimensions are 150x150 px

 

 

 

Products tab:

In this tab, you are to select the products
associated to the brand. Just select required
products and click Save or Save and Continue edit.

It is also possible to assign brand in the product
settings page ->Product Brand tab, and in Catalog
->Products grid by selecting required products and
applying action "Update Attributes" (i.e. with batch
update).

Brand Page tab:

Page Title - sets the Brand Page SEO
Title
URL key - defines the URL to the brand's
page
Brand Description - WYSIWYG / HTML
editor. Will be displayed in the top of the
Brand's page next to Brand Image. 
Meta Keywords, Meta Description - the
options to define Meta keywords and
description respectively.

 

Note: if image files of different dimensions are
used, the extension will resize them to the
mentioned values. If you would like the Icon and
Image have different dimensions, check these
instructions.
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Customization

Editing Layout
To change the layout, one need to edit the file
app/design/frontend/[your_package]/[your_theme]/layout/aw_shopbybrand.xml

To move the Brands List block to right column, find the following code:

and change it to:

 

To change the columns layout from "2-columns left", find the following lines:

and change it to one of the following lines:

 

The quantity of products displayed per row in brand page grid can be changed in the following part of
the code:

where '4' is the number of product by default.

 

Changing image dimensions
By default, the extension is supposed to work with square images ( X px wide * X px high). If you need to use
rectangular image (X px wide * Y px high), you can do the following.

<reference name="left">

<reference name="right">

<template>page/2columns-left.phtml</template>

<template>page/2columns-right.phtml</template>
 
<template>page/3columns.phtml</template>
 
<template>page/1column.phtml</template>

<action method="setProductsInRow">
<columns>4</columns>
</action>
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Search through the following files:

app/design/frontend/[your package]/[your theme]/template/aw_shopbybrand/allbrands.phtml
app/design/frontend/[your package]/[your theme]/template/aw_shopbybrand/brand.phtml
app/design/frontend/[your package]/[your theme]/template/aw_shopbybrand/brandsbar.phtml
app/design/frontend/[your package]/[your theme]/template/aw_shopbybrand/productpage.phtml

for all the instances of this code:

You can change the image dimensions to your preferred value by altering the parameters in brackets.

After you are done with editing the files, flush the store cache and check the result.

 

Inserting More From Same Brand block
 

Since version 1.3.0, the extension allows inserting a special "More From Same Brand" block. This block shows X
more items assigned to the same brand.

The block can be inserted via CMS or via a direct call in page template file. 

 

 

Uninstallation

To insert the block via CMS

to a Product View page: 

 column_count and row_count parameters define the number of products in block. You can use your values for
these parameters, if they are omitted, default values "2*2" will be used.

to a Category or Static CMS page:

NOTE: as you can see, the 2nd variant requires specifying Product ID parameter; if a block is inserted into a non-
product page, the extension is not capable of recognizing what product to associate the block with, unless the
product Id is specified explicitly.

 

 

src="<?php echo $this->getImageUrl(50, 50); ?>"

{{block type="awshopbybrand/widget" column_count="3" row_count="1"}}

{{block type="awshopbybrand/widget" product_id="1" column_count="3" row_count="1"}}
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Нравится Станьте первыми кому понравится
это

If you only need to disable the module on frontend, go to System->Configuration->Advanced->Advanced-
>Disable modules output and set the module AW_Shopbybrand to 'Disabled' value.
To completely remove the extension and all it's settings do the following:

1. Backup your database.
2. Run the following query in your MySQL:

If you are using the table with prefixes, they must be specified as well. 
If you are not sure how to do that or expect any troubles with it, please contact your server
administrator regarding the matter. 
 

3. Now it is safe to delete the files of the extension, starting from app/etc/modules/AW_Shopbybrand.xml 
 

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento
installation procedure.

Change the owner of the extracted extension files to the web server user and set 775 permissions on them.
Clear the store cache and try again.

 After the installation System->Configuration->Shop By Brands returns 404 error.

Logout from backend and login back again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked
I get a blank page, or Access Denied error.

Clear the store cache, browser cookies, logout and login again.

My configuration changes do not appear on the store.

 Clear the store cache, clear your browser cache and domain cookies and refresh the page.

I can not upload the logo and images for brands.

Make sure to set full permissions (777) to the folder /media/aw_shopbybrand/ and all it's subfolders.

 

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2019 aheadWorks Co. http://www.aheadworks.com

 

 

DELETE FROM `eav_attribute` WHERE `attribute_code` =  'aw_shopbybrand_brand';
DELETE FROM `core_resource` where `code` = 'awshopbybrand_setup';
DROP TABLE `aw_shopbybrand_brand_flat`;
DROP TABLE `aw_shopbybrand_brand_product`;

Ни одной
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