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Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

Having hard time
finding an answer to
your question?

Check out our
Knowledge Base.

IMPORTANT NOTE FOR users of Refer a Friend 1.X
Versions 1.X and 2.X are not compatible. This means that 2.X can not use the rules and manage discounts
from 1.X. The migration script included into the package will import the lists of existing referrers and referrals
only (see the details below). Due to significant changes in the extension's design, existing discounts can not
be imported and will be lost. You will need to add the bonuses manually (new version allows that). If you are
currently running a referral campaign with RAF 1.X, please consider ending it prior to the installation of the
new version.

http://confluence.aheadworks.com/display/EUDOC
http://confluence.aheadworks.com/display/EUDOC/Documentation+Home
http://confluence.aheadworks.com/display/~lashuk
http://confluence.aheadworks.com/pages/diffpagesbyversion.action?pageId=20939444&selectedPageVersions=10&selectedPageVersions=11
http://confluence.aheadworks.com/display/EUDOC/Refer+a+Friend
http://ecommerce.aheadworks.com/magento-extensions/refer-a-friend.html
http://ecommerce.aheadworks.com/kbase/extension-refer-a-friend/
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you
use "Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
The extension comes with 2 design packages: /base/default/ and /rwd/default/ .

In case you are using a custom theme, it is recommended to copy the design files to your current
theme's folders. In case there are several themes in use at the same store, the design files must be
copied to each of them.
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 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

 

Migration from Refer a Friend 1.X
1. Make sure that Refer a Friend 2 is installed successfully
2. Backup your database
3. Copy the file awraf_export.php to your store root folder if it was not copied during the installation.
4. Execute it under your browser, i.e. simply go to http://YourStore.com/awraf_export.php.
5. After the migration is complete, make sure to delete the file awraf_export.php by security reasons. 

Configuration

Global settings
The General Configuration section of the extension is located in Refer a Friend →
Configuration (or System → Configuration → aheadWorks Extensions → Refer a Friend ).

General tab

Calculate Purchase Amount As('Item Price' /
'Item Price + Tax') – This option defines
whether the discount specified in the rules (see
below) should be calculated considering tax
settings. 
 
Allow Usage With Coupons ('Yes/No') -
Determines whether the discount can be
applied together with coupons and Shopping
Cart Price Rules. 
Both Coupons and Shopping Cart Price Rules
have higher priority than the Refer a Friend
discounts, so when set to 'No', this option will
prevent customer from applying a discount if
any Shopping Cart Rule has been triggered. 
 
Max discount % to order – maximum amount
of discount (percent type) which can
be applied to an order.  
Depending on the rules settings, referrer can
obtain quite a significant discount. This option
will limit the possibility to use both fixed and
percent discount types. 
Example: a referrer earned 78% in total, but if
this option is set to 15, the referrer can use

 

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

http://yourstore.com/
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15% Off discount at a time only. 
 
Apply discount if cart total is equal or
greater than – this option defines minimum
cart total amount allowed for discount usage.
This option works both for fixed and percent
discount. 
Example: If the option is set to 99, it will be
impossible to apply a discount to a cart unless
the current subtotal reaches $99. 
 
Minimum discount to be able to redeem –
 customer can not spend less than specified
here. This option applies to fixed discount only. 
Example: if this option is set to 25, Referrer
can not use their discount at all, until they earn
25$ or more. However, they still can apply their
10%.

 

 

Referral

 

Invitation

Allow invitation (Yes/No) – When set to 'No',  

Recognize referrals by option defines how
the extension should recognize referrals:

If Referral Link is selected new
customers will only be considered
referrals if they have proceeded
to the store by the invitation link
sent;
If Email Address is selected new
customers will be considered
referrals if they have registered
the account under the same
email address the invitation has
been sent to. 
 

Give bonus to referral for
registration (Yes/No) – determines whether
referred friend will get any bonus. 
 
Bonus type (Fixed discount/Percent
Discount) 
Important: If Bonus type is Percent
Discount, referrer will be able to use it
indefinitely. However, admin can edit or

delete this discount manually in Refer a
Friend → Manage Discounts later. 
 
Bonus amount - The amount of discount
which referral will earn after registering at the
store. 
Note, if referral logs in (rather than create a
new account on the site), they are considered
to be an existing customer and therefore, will
not earn the bonus. Referrer will not receive
any bonus for that referral's activity either.
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only Broadcast links and Sharing features are
available. 
 
Email sender and Select email template -
these self-explanatory options define the
Sender and the Template of the Invitation
message.  
 
Redirect to: Here one can define the URL of
the page where referral will be redirected to
after clicking the referred link. 
The option should have the
format http://yourstore.com/somepage.html

 

Advanced 

Reset all rule activities – this button will
reset all transactions, discounts and
statistics. This option will not delete existing
rules, though.

 

 

 

Managing rules
The rules can be created and managed in Refer a Friend → Manage Rules backend tab.

After you click Add New Rule button, make sure to set it up properly prior to saving. Some of the rule
parameters are not editable after a rule gets saved.

The options are:

Rule Name — a text field, you can specify any recognizable name 
 
Rule Type – there are 3 different types:

1.  Store sign up. Referrer will receive a bonus for
the sign ups of his referrals (no purchases
required). 
2.  Discount for a number of items. Referrer will
get a bonus for the certain (or greater) amount of
items purchased by referral(s). Since the version
2.1.1 this option works 'per-friend'. 
3.  Discount for referrals' purchase
amount. When referral(s) spend a certain sum,
referrer will get a bonus. Since the version 2.1.1
this option works 'per-friend'.. 
 
Discounts are added to referrer when referral's
order(s) obtain 'Invoiced' status.

 
 

 

Bonus Type there are two options for each rule type: Fixed flat rate and percent discount. Customer can
use both percent and fixed discount on a purchase at a time.

Note, if several rules with percent discounts
triggered at a time, a greater discount will be used
only, without summarizing them. For example,

http://yourstore.com/somepage.html
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there are two rules set: the first one provides 20%
off, another one gives 30%. If both rules have
been triggered, referrer will receive 30% off (the
greater discount of those two will be applied). 
Important: In current version, the percent discount
does not have an expiration option, so basically, it
is a lifetime discount. However this discount can
be canceled by admin. Also, it's amount can be
limited with the option Max discount % to
order in Refer a Friend → Configuration →
General.

 
 
Active From * Specify the date when the rule is to start working.

 

Target * This is one of the most important
options, which depends on Rule Type: 
 
1. if Rule Type is 'Store sign up' → Target
= Quantity of sign ups required to trigger the
rule. 
2. if Rule Type is 'Discount for a number of
items' → Target = Number of items which
referrals have to purchase to trigger the rule. 
3. if Rule Type is 'Discount for referrals'
purchase amount.' → Target = Minimal
amount which should be spent by referrals in
the store to trigger the rule. 
 
Bonus Amount * Depending on Bonus Type,
it can be set in base website currency or in
percent.

 

 

Trigger limit - This option defines how many
times the rule bonus can be earned by the
referrer. E.g., if you set up a rule to give a
bonus for 5 items purchased by the customer's
referrals, and set the Trigger Limit to "1", the
bonus will only be granted once, when the rule
amount is reached for the first time. If
the Trigger Limit is set to "2", the bonus will
be granted for the referrals' purchasing 5 and
10 items. If the Trigger Limit = "3", the bonus
will be granted for 5, 10 and 15 items. Also,
check the description of the option 'Save
Remainder For Later Usage' . If the Trigger
Limit option is left empty (i.e., "no limit"), the
referrer will earn the bonus each time the
Target amount is reached.

Save Remainder For Later Usage - This
option complements the Trigger Limit option,
and defines how the target amount is
calculated for a multi-trigger rule. This is how it
works: The rule is to give a discount for 3 items
purchased. If the option to save remainder is
'No', a friend must purchase at least 3 items in
a single order. If the option is set to 'Yes', the
quantity of purchased items can be split into
several orders: the friend can purchase 2 items
in one order, and then 1 item in the next one. 
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Rule Priority – the higher the value is, the
more priority the rule has.
Stop Further Rules Processing: When set to
'Yes', all rules with priority lower than the
current one will not be triggered.
Status Enabled/Disabled
Store view * Choose store view where the rule
is active.

 

 

After the rule is created, click Save or Save and Continue Edit. 

 

 

 

 

Other pages
Refer a Friend → Manage Discounts and Refer a Friend → Manage Transactions pages are generally
the same.  
The difference is Manage Discounts displays the information about percent-rate bonuses, while Manage
Transactions shows transactions with flat amount. 
Admin has a possibility to add both flat and percent discounts manually. In Manage Transactions it is also
possible to subtract balance by entering a negative value. 
 
Refer a Friend → Statistics The page which shows statistics by referrer.  
It is possible to export it to CSV or XML file format.

 

Custom position
To insert “Invite a friend” button into CMS block or page use the following variable:

Make sure to remove all buttons before uninstallation.
Do not insert this code directly into phtml.

 

Uninstallation
Disable compilation, in case it is enabled.

1. Remove all extension's buttons and widgets inserted manually.

Note, after the rule is saved, the options Rule Type, Bonus Type and Active From can not be modified.

{{block type="core/template" name="invite_block" template="aw_raf/invite_button.phtml"}}
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2. Login to your FTP, navigate to app/etc/modules/

3. Open the file AW_Raf.xml and change the following line:

<active>true</active>

to

<active>false</active>

Now your Magento is unaware of the existence of this module.

4. Clear the cache under var/cache

5. Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.

6. If everything works fine, it is safe to delete the files of the extension.

7. In case you need to clean the database, make a backup and then run the following query in MySQL:

Note, if you are using the tables with prefixes, you have to specify them in all table names before running
the query above. 
 

If you are not sure how to do that or expect any troubles with it, please contact your server administrator
regarding the matter
If you remove the tables as it is described above, you will need to create all rules again after the extension is
reinstalled. All transactions and statistics history will be lost as well.

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento
installation procedure.

Change the owner of the extracted extension files to the web server user and set 775 permissions on them.
Clear the store cache and try again.

 After the installation System->Configuration->Refer a Friend returns 404 error.

Logout from backend and login back again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked
I get a blank page, or Access Denied error.

Clear the store cache, browser cookies, logout and login again.

My configuration changes do not appear on the store.

 Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

drop table if exists `aw_raf_rule`;
drop table if exists `aw_raf_activity`;
drop table if exists `aw_raf_transaction`;
drop table if exists `aw_raf_discount`;
drop table if exists `aw_raf_referral`;
drop table if exists `aw_raf_trigger`;
drop table if exists `aw_raf_orderref`;
drop table if exists `aw_raf_statistics`;
delete from `core_resource` where code = 'awraf_setup';

http://ecommerce.aheadworks.com/contacts/
http://ecommerce.aheadworks.com/
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Нравится Станьте первыми кому понравится
это

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2019 aheadWorks Co. http://www.aheadworks.com
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