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Extension page: http://ecommerce.aheadworks.com/product-questions.html

Stay in touch with your visitors and customers with the help of the Product
Questions module. It adds the Questions page to each product. Visitors ask
questions about products and the store administrator answers them.

Then the questions and their answers appear on the Questions page enriching
your site content and providing user-demanded text contribution to your items.
There is an ability to reply to the question by email without publishing it.

Besides all benefits, the extension provides more comfortable way to reach store
representative and get necessary information. No need to look for a contact form,
choosing department, copy-pasting the product title etc. - just click the link on the
product page and type in your own question or see what others have asked.

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to
System -> Tools -> Backups and perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

Having hard time
finding an answer to
your question?

Check out our
Knowledge Base.
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IMPORTANT: after the extension is installed, you can enable the
compilation again; IT IS CRUCIAL that you use "Run Compilation
Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush
Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to
/var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the
downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

Installing an extension with the Compilation enabled will result in store
downtime.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy
the design files to your current theme's folders. In case there are
several themes in use at the same store, the design files must be
copied to each of them.

Find this folder in the package:
/step_1/app/design/frontend/base/default/ ; copy its content
to /app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package:
/step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/
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Inserting link to a separate Questions page

 
Click here to expand...
Product Questions extension will appear in a new page (like Reviews). If you
need to show "questions/answers/ask a question from" on your product page
(e.g. in tabs), please refer to the next section.

Open file:
/app/design/frontend/<your_package>/<your_theme>/template/catalog/pro
duct/view.phtml (where <your_package> is a name of your current design
package, and <your_theme> is a current theme name. If you use standard
Magento theme, this should be /default/default/ ).

 

Find the string:
 

 

and insert the following code right after it:
 

This will insert the Be first to ask about this product link just under the
Review product link. If there will be 1+ questions the link will be Ask a
question.

 

Inserting Questions into the Product Page
 

Click here to expand...
open
file /app/design/frontend/<your_package>/<your_theme>/template/catalog/
product/view.phtml and insert the following line:

 

just above the line:

 

Then, to insert the Questions block:

open /app/design/frontend/<your_package>/<your_theme>/layout/catalog.
xml

Place inside the catalog_product_view -> content node
 

<?php echo $this->getReviewsSummaryHtml($_product, false, t

<div class="productquestions-summary"><?php echo Mage::help

<?php echo $this->getChildHtml('productquestions_form') ?>

<?php echo $this->getChildHtml('upsell_products') ?>
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the following lines:
 

 

To show Ask A Question form:

open /app/design/frontend/<your_package>/<your_theme>/layout/catalog.
xml and insert the following line in the appropriate place.
 

 

Configuration
To configure the extension, navigate to System > Configuration > aheadWorks
Extensions > Product Questions.

It is obligatory to save config before using the extension.

Here you can define different options.

Don't forget to fill in the Send Emails To field with a correct e-mail address,
because it's a place where you will receive email notifications.

Clear Magento cache.

Composing Email templates
The extension sends 2 types of emails: Notification Emails (emails sent by
autoresponder) and Answer Emails (emails sent to customer when the admin
replied on the question).

There are a variety of objects available for the email template processor when
preparing the emails to be sent.

 
List of available variables - click to expand

Name Type Meaning Notes Example

<catalog_product_view translate="label">
    ...
    <reference name="content">
        <!-- place below this line -->
        ...
    </reference>
    ...
</catalog_product_view>

<block type="productquestions/questions" name="productquest
    <block type="productquestions/sorter" name="productques
    <block type="page/html_pager" name="productquestions_pa
</block>

<block type="productquestions/form" name="productquestions_
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Name Type Meaning Notes Example

question_text string Question
text

The question asked {{var que

reply_text* string Reply text The answer to the
question

{{var rep

date_asked string A date
when the
question
was
asked

The value is
formatted according
to current locale
settings

{{var dat

customer_name string Customer
name

The name of the
customer who
asked a question

{{var cus

customer_email string Customer
email

The email address
of the customer
who asked a
question

{{var cus

product_name string Product
name

The name of the
product being
asked about

{{var pro

product_url string Product
URL

The URL leading to
the product page

{{var pro

store_url* string Store
base URL

The URL leading to
the store from
where the question
was asked

{{var sto

store model Current
store

The instance of the
'core/store' model
class

{{var sto

product model A product
being
asked
about

The instance of the
'catalog/product'
model class

{{var pro

customer model A
customer
asked the
question

The instance of the
'customer/customer'
model class (if
there is registered
customer with the
same email)

{{var cus

*For Answer Emails only

 

RSS feed
The RSS feed option allows customers to be informed when a new question about
a product appears. A separate feed is available for each product .

There are RSS Feed groups on the configuration page that allows to specify the
RSS feed title, image, and quantity of questions shown in the feed (ordered by
date questions were asked). The RSS feed title can be customized to obtain more
details by including the following macros fields:

{product_name} - The Product name,
{store_name} - The Store name
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{store_url} - the Store URL,
{website_name} - the Website URL

Show last X questions
The Show last X questions option allows you to limit the number of questions
displayed on the Product Details page. This option is not applicable to the Product
Questions page, and if it is defined, the pager toolbar will not be displayed.

Widget
Open a static block or CMS page, where you want the Product Questions block to
be displayed at, and insert the block as a widget. Also you can use the following
text in the content field:

where num_questions is a quantity of questions to be displayed

url_type=0 - redirect to the Product Questions page

url_type=1 - redirect to the product page.

Troubleshooting
After the extension installation the store gives an error, or blank page, or
suggests to start Magento installation procedure.

    Change the owner of the extracted extension files to the web server user and
set 775 permissions on them. Clear the store cache and try again.

There is no aheadWorks extensions under my configuration section, or
having the extension tab clicked I get a blank page, or Access Denied error.

    Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing
on that page.

    Clear the store cache, clear your browser cache and domain cookies and
refresh the page.

My configuration changes do not appear on the store.

    Clear the store cache, clear your browser cache and domain cookies and
refresh the page.

 

You can always find the latest version of the software, full documentation, demos,
screenshots and reviews at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2015 aheadWorks Co. http://www.aheadworks.com

 

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

{{widget type="productquestions/widget_block" num_questions="5

http://ecommerce.aheadworks.com/
http://ecommerce.aheadworks.com/LICENSE-M1.txt
http://ecommerce.aheadworks.com/contacts/
http://www.aheadworks.com/
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If you are going to use the native Magento backup function, navigate to
System -> Tools -> Backups and perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

IMPORTANT: after the extension is installed, you can enable the
compilation again; IT IS CRUCIAL that you use "Run Compilation
Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush
Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to
/var/cache/; delete all the content there.

Installing an extension with the Compilation enabled will result in store
downtime.
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Нравится Станьте первыми кому понравится это

 5. Download the extension package from your account and extract the
downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

If you are using a custom theme,
read the instructions here.
The extension comes with 2 design packages: /base/default/ and
/rwd/default/ .

In case you are using a custom theme, it is recommended to copy
the design files to your current theme's folders. In case there are
several themes in use at the same store, the design files must be
copied to each of them.

Find this folder in the package:
/step_1/app/design/frontend/base/default/ ; copy its content
to /app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package:
/step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

Ни одной
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