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Extension page: http://ecommerce.aheadworks.com/magento-extensions/points-and-rewards.html

This Magento extension offers points & rewards system implemented as well as the referral program. Points can be
awarded automatically (and manually by the merchant) for making purchases, reviewing products, inviting friends, or
carrying out any other admin-specified action. Later these points can be redeemed for discounts.

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

Having hard time
finding an answer to
your question?

Check out our
Knowledge Base.

http://confluence.aheadworks.com/display/EUDOC
http://confluence.aheadworks.com/display/EUDOC/Documentation+Home
http://confluence.aheadworks.com/display/~lashuk
http://confluence.aheadworks.com/pages/diffpagesbyversion.action?pageId=16910345&selectedPageVersions=69&selectedPageVersions=70
http://confluence.aheadworks.com/display/EUDOC/Points+And+Rewards
http://ecommerce.aheadworks.com/magento-extensions/points-and-rewards.html
http://ecommerce.aheadworks.com/kbase/extension-points-and-rewards/
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you
use "Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current
theme's folders. In case there are several themes in use at the same store, the design files must be
copied to each of them.

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
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 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

Set up cron

The Rewards & Points extension uses cron for checking points expiration and sending notifications about points
expiration. Read the following instructions on setting cron job for your Magento store: Magento user guide. If you have
already configured cron jobs for your Magento installation then you can skip this step.

Generally it would be enough to run in SSH console of your server: 
crontab -e

And add the following line: 
 

*/3 * * * * wget 'http://your-store/cron.php'

Don't forget to confirm saving request when exit. 
If you are not sure how to do that or experiencing any troubles with it, contact your server administrator or hosting
provider regarding the matter.

Zero Checkout

Providing you want to let your customers to checkout
solely with points (paying for the whole order with points)
the Zero Subtotal Checkout should be enabled.

To enable Zero Subtotal Checkout navigate to your
Magento backend System > Configuration > Sales>
Payment Methods > Zero Subtotal Checkout and set
'Enabled' field to 'Yes'.

Now your customer can checkout with points solely.

Configuration
 

 

Basic configuration

Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

Configuring the Point And Rewards extension has several obligatory steps:

1. Specifying general parameters (see below)
2. Setting up Points Rates

http://merch.docs.magento.com/ce/user_guide/Magento_Community_Edition_User_Guide.html#system-operations/cron.html#kanchor1045
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The extension's general settings can be specified in System-> Configuration-> aheadWorks Extensions-> Points
And Rewards (or in Promotions-> Points And Rewards-> Configuration) backend page.

General

Enable - activates / deactivates extension's
functionality
Points Unit Name - this option defines the frontend
points unit title
Enable rewards history - shows / hides the
Transactions History block in the frontend customer
dashboard
Enable reward rules functionality - enables /
disables points rules
Show points block at product page -
enables/disables the pre-calculated earned points
amount block in the product view page

Points earning calculation(Before Tax/ After Tax)
and Points spending calculation(Before Tax/ After
Tax) - these options define how the tax amount is
treated in the calculations

Cancel earned points after order refunding -
removes the points earned for an order in case this
order gets refunded.
Restore spent points after order refunding -
returns the points spent on an order in case it gets
refunded.

How does this block look like?

How exactly are the amounts calculated?
For Earning

Before Tax: Points = (Subtotal -
Discounts) * Earn Rate
After Tax: Points = (Subtotal + Tax -
Discounts) * Earn Rate

For Spending

Before Tax: Grand Total = (Subtotal -
Discounts) - Points * Spend Rate + Tax
+ Shipping Price
After Tax: Grand Total = (Subtotal + Tax
- Discounts) - Points * Spend Rate +
Shipping Price

 

NOTE:

the Shipping amount is neither used for
earning calculations, nor can it be paid
with the reward points;
Tax includes all the taxes applied:
shipping tax, product tax, etc.
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Minimum reward points balance to be available
to redeem - sets the minimum required to apply
points. A customer cannot use the points if their
current balance is below the value specified in this
field
Maximum available points balance - sets the
upper limit on the available balance. A customer
cannot accumulate more reward points than the
value set in this field at a given moment
Reward points expire after, days - sets the points
expiration period
Amount available for paying at checkout by
points, % - this option restricts the portion (in %) of
the order total that can be covered by the points.
E.g., if this option is set to 50%, a customer will only
be able to pay half of the total with points.
Info page - this selector allows you to select a
Static CMS page, where the details on the reward
program are explained. The link to the selected
page will be included in several blocks

Can use points with Magento coupon - allows /
prohibits applying the points together with the native
Magento coupons. If this option is disabled, using
any discount code at the Shopping Cart will remove
the option for using Reward Points during the
checkout.

 

Earning Points

 

In this tab, you can define the rewards for non order-related activities (sign-up, reviewing products, etc). The rewards
setup in this tab are awarded even in case the Earn Rate is not specified.

Registration - here, you can specify the reward for
creating a new customer account
Newsletter signup - reward for subscribing to NL
Consider newsletter subscription by admin -
defines whether the reward will be granted if the
store admin subscribes a customer
Reviewing product and Reviewing product
points/day limit - these options set the reward for a
product review and the daily limit* for earned points
respectively.
Minimum number of words in the review -
defines the minimal review length that qualifies for

Where exactly will this link be placed?
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the reward
For Video Testimonials and For Video
Testimonials points/day limit (require Video
Testimonials extension) - set the reward for a
submitted testimonial and the daily limit* for earned
points.
Only those who purchased product can gain
points - limits points earning to the customers who
have actually purchased the reviewed product.
Tagging product and Tagging product
points/day limit - set the reward and the daily limit*
for tagging an item.
Participating in poll and Participating in poll
points/day limit - set the reward and the daily limit*
for voting in a poll.
Customer birthday - sets the reward granted when
the specified customer birthday date arrives. If the
Birth Date is not specified in the account settings,
no bonus will be granted.

 

*Daily limit restricts the total amount of points a customer
can earn for the correspondent activity a day. Once the
limit is reached, the customer can still take the same
actions, but no extra rewards will be granted.

 

 

 

Referral System

 

The Points And Rewards  extension features referral system. It is possible for a customer to earn the points for
inviting friends, and for their referral's orders. The personal Invitations can be sent from the special area in a customer
account dashboard. Referring people is also possible via special broadcast link, which can be posted in public
sources.

Enable referral system - activates / deactivates
the referral bonuses
Points for inviting a friend - sets the amount of
points for inviting a friend (the points are added
after a referral navigates to the store and creates an
account)

For Product Questions 2 users
If you have Points And Rewards version
1.7.3+ and the Product Questions 2 extension
installed, an extra option will become available
in the Earning Points tab:

This option allows rewarding customers for
answering product questions.

All referral bonuses are awarded only for the registered users' activity. I.e., if an invited person makes any
purchases at the store without creating an account, their referrer will not receive any rewards.

http://ecommerce.aheadworks.com/magento-extensions/video-testimonials.html
http://ecommerce.aheadworks.com/magento-extensions/product-questions.html
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Day limit for points for inviting a friend - this
option restricts the total amount of points a
customer can earn for invitations a day. After the
limit is reached, the customer will still be able to
send invitations, but they will not get the rewards for
the "extra" invitations
Points awarded to customer for their referrals'
purchases (Each Order / First Order) - defines
whether a referrer will earn bonus for their referral's
initial order only, or for each of their subsequent
orders as well. The points are granted when a
referral's order reaches "Complete" state.  
Note, this limit is per-referral
Points awarded to customer for their referral's
purchases (fixed and % amounts) - sets the
actual amount of referral bonus.  
Note, the 2 amount stack, so if you specify both
kinds of bonus, a referrer will earn fixed + %.

Notifications

The extension's notifications can be configured in System-
> Configuration-> aheadWorks Extensions-> Points
And Rewards-> Notifications.

In this tab, you can Enable the emails, select their Sender
and the templates for each of the supported message
types: 
Balance Update, Points Expiration, Customer Birthday
and Invitation email 

Subscribe customers by default (Yes / No) option
defines whether the customers will be automatically
subscribed to module's notifications.

Email sending before points expiring (in days) option
sets the period before the expiration when the expiration
warning will be sent.

Advanced

Reset all transactions option is meant for moving a store
from staging to live. Clicking this button will set balance to
"0" for all the customers, transactions history will be
cleared up as well.

The extension's settings, rules and rates will not be
deleted.

Points Rates
 

The Earn and Spend rates define the conversion rates of point units.

The rates can be set in Promotions-> Points And
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Rewards-> Points Rates-> Earn / Spend Rate.

Spend Rate defines how points are treated when
applied to an order. Setting Spend
Rate is obligatory, no points earned for any kind of
store activities can be applied unless the spend
rates are set.
Earn Rate defines what percentage of the
customers spendings will be converted to points. If
no Earn Rates are created, a customer will only be
able to receive points for general store activities, for
referring friends and via the special points rules. 

 

A rate setup is pretty straightforward: you can choose the
website and customer group (s) the specific rate will apply
to.

The rate itself is set like X $ >> Y Reward Point(s) for
earning and X Reward Point(s) >> Y $ for spending

NOTE: Do not use decimal values in rates. If you need to set up 10% rebate rate, set it like this: 10$ >> 1 point . If
you need 1 point to equal $0.1 on the checkout, set it up like 10 points >> $1 

 

 

Points rules
 

Along with the regular rewards for store activities and the % of spendings, the Points And Rewards extension allows
providing special fixed-amount points bonuses if an order meets certain conditions.

This option is implemented via rule system, similar to the standard Shopping Cart Price Rules. The points rules can
be created and managed in Promotions-> Points And Rewards-> Reward Rules grid.

The rule configuration is mostly identical to any other Magento rules. In General Information tab, you are to specify
the basic rule parameters (Name, Description, Status, From-To Dates, etc). In Conditions tab, you can define the
actual criteria for triggering the rule (Available conditions are based on Shopping Cart contents).

In Actions tab, you can specify the actual rule reward.

Note, that the module only supports fixed amount actions.
No % or other values types are allowed.

 

In Related Blocks tab, you can choose the info block to be displayed in the Shopping Cart page if rule is triggered.
You can select any of the existent CMS blocks.

 

The point rule conditions are similar to that of native Magento Shopping Cart Price rules.

Meaning that for the reward rules only the Subtotal value will be available.

Where will this block appear?
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Coupons
 

The Points And Rewards extension allows issuing coupons (or vouchers) - special codes that can be applied in the
customer account dashboard. Applying a coupon immediately updates the reward points balance, the target points
bonus is instantly granted.

Applying a coupon is a one-time operation, and a given
coupon can be used only once per account. The general
number of uses can be specified in the coupon settings -
see below.

The coupons can be setup in  Promotions-> Points And
Rewards-> Coupons grid.

The standard options include Coupon Name ,
Description, Websites and Customer Groups selectors,
From-To Dates and coupon Status.

Coupon Code - in this field, you should specify the
actual voucher code that your customers will need
to submit to gain the bonus. You can use any text
here. The extension does not generate any codes
automatically.
Uses per Coupon - limits the total number of
voucher uses
Activation Count - this counter will show the total
number of coupon activations.

 

How can customers apply a coupon?
A points coupon can be activated in the
Reward Points tab in frontend customer
account dashboard, there is a special field for
applying the coupon
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Transactions
 

The extension keeps record of every points-related
transactions. You can view them on per-customer basis (in
the Reward Points tab of the backend Customer View
screen), or for the entire store in Promotions-> Points
And Rewards-> Transactions.

From the Transactions grid, you can also perform mass
balance updates. You should just click Add New button,
select the customers (if Market Segmentation Suite is
installed, you can use its rules to filter the customers ), and
specify the transaction comment and amount*.

*Negative values are also allowed, in this case, saving the
transaction will subtract the target amount from customers'
current balance.

Current Balance widget
The Points And Rewards extension adds a new widget
type: AW Points Balance

This widget is displayed for logged in users, and show the
current points balance of their accounts. The usage is
identical to any standard Magento widgets

 

Integration with other aheadWorks modules
The Points And Rewards extension features integration with the
following aW products:

Market Segmentation Suite - the MSS rules can be applied to
customer list when adding mass transaction.

Video Testimonials - if this module is installed, you can reward
your customers for submitting product videos.

 

Click to see the screenshot

http://ecommerce.aheadworks.com/magento-extensions/market-segmentation-suite.html
http://ecommerce.aheadworks.com/magento-extensions/market-segmentation-suite.html
http://ecommerce.aheadworks.com/magento-extensions/video-testimonials.html
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Product Questions 2  - if this module is installed, you can
reward your customer for answering Product Questions. New
option appears in the Earning Points tab of the modules' s
config.

 

Important notes
 

Points section is located at the Payment Section at the Checkout page (4th step), so if payment method with its
own checkout (e.g. PayPal) is used and it is selected on the Shopping Cart page (e.g. the Check out with
PayPal button is clicked) , points can not be applied as discounts. The best solution here is to disable this
payment button for the Shopping Cart page (Example for PayPal Express at Magento 1.5: go to System >
Configuration > Express Checkout Settings > Shortcut on Shopping Cart and set 'No')

For Magento 1.3 only: the extension is NOT compatible with PayPal.

Please, note that different Payment Gateways process the order payments in different ways, some of them do
not accept the zero-subtotal orders.

If you allow your customers to fully pay the order amount with the reward points, please, make sure that your payment
methods accept such orders. 
In case your payment provider turns out not to allow it, you can consider the following scenarios: 
- allow Zero Checkout payment method at your store; 
- specify the point usage limit via the "Amount available for paying at checkout by points, %" option in System->
Configuration-> aheadWorks Extensions-> Points And Rewards-> General backend menu; 
- try switching the "Points spending calculation" option between "Before Tax" and "After Tax" to see whether the
payment method starts accepting the orders.

The points block at product page will only be displayed for Simple, Virtual,
Downloadable and Configurable products. For the Grouped and Bundle items, this block will not be shown.

 

Uninstallation
 

If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.

Disable compilation, in case it is enabled.
Login to your FTP, navigate to app/etc/modules/
Open the file AW_Points.xml and change the following line:

to 

Now your Magento is unaware of the existence of this module.
Clear the cache under var/cache
Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
If everything works fine, it is safe to delete the files of the extension.
In case you need to clean the database, backup your database and then run the following queries in MySQL: 

 

<active>true</active>

<active>false</active>

DROP TABLE IF EXISTS `aw_points_coupon`;

http://ecommerce.aheadworks.com/magento-extensions/product-questions.html
http://ecommerce.aheadworks.com/contacts/
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Нравится Badeev, Vitaly likes this

Note, if you are using the table with prefixes, you must specify them in all table names. 

If you are not sure how to do that or expect any troubles with it, please contact your server administrator
regarding the matter. 
If you remove the tables as it is described above, you will need to create all rules again after the extension is
reinstalled. All transactions history will be lost as well.

 

Troubleshooting
 

After the extension installation the store gives an error, or blank page, or suggests to start Magento
installation procedure.

    Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.

After the extension installation I receive 404 error in System->Configuration->Points & Rewards.

    Logout from backend and login back again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get
a blank page, or Access Denied error.

    Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing on that page.

    Clear the store cache, clear your browser cache and domain cookies and refresh the page.

My configuration changes do not appear on the store.

    Clear the store cache, clear your browser cache and domain cookies and refresh the page.

I have enabled and configured the extension, but the Apply Points option does not appear in the checkout.

    Make sure that you have setup Points Spend Rate. 

 

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2019 aheadWorks Co. http://www.aheadworks.com

 

DROP TABLE IF EXISTS `aw_points_coupon_transaction`;
DROP TABLE IF EXISTS`aw_points_transaction_orderspend`;
DROP TABLE IF EXISTS `aw_points_transaction`;
DROP TABLE IF EXISTS `aw_points_invitatioin`;
DROP TABLE IF EXISTS `aw_points_rate`;
DROP TABLE IF EXISTS `aw_points_rule`;
DROP TABLE IF EXISTS `aw_points_summary`;

delete from core_resource where code ='points_setup'; 
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