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Gift Card/Certificate 2.0

Extension page: http://ecommerce.aheadworks.com/magento-extensions/gift-card-certificate.html

If you are Gift Card 1.x branch extension user refer to the Gift Card/Certificate 1.x readme.

Installation

Gift Card 1.x user notice:

Gift Card 2.x branch is NOT compatible with the previous versions of the extension and require separate
installation.

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

(&) Backups h stem Back i

Page 1 of 1 pages | View |20 | perpage | Total O records found

glect All | Unselect All | Select Visible | Unselect Visible | 0 items selected Actions. v m

i

2. Log in to the Magento backend

3. Disable compilation
Click to view details
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Navigate to System -> Tools -> Compilation.
If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

@ Compilation -

Compilation State

Compiler Status
Compilation State

Collected Files Count

Compiled

7505

IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

‘& Compilation

Compilation State
Compiler Status Disabled

Compilation State Compiled

Collected Files Count 7505

Installing an extension with the Compilation enabled will result in store downtime.

4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

¢ via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

Cache Storage Management

Select All | Unselect All | Select Visible | Unselect Visible | 0 items selected Actiunsl Refresh ¥ wr_"i
Cache Type Description Associated Tags Status
[ Cenfiguration System(cenfig.xml, lecal xml) and modules configuration CONFIG
files(config.xml).
[ Layouts Layout building instructions. LAYOUT_GEMNERAL_CACHE_TAG ENABLED
Blocks HTML output Page blocks HTML. BLOCK_HTML [ EnaBLED ]

« via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

5. Download the extension package from your account and extract the downloaded archive

6. Copy the content of /Step_1/ folder to your store's root directory

If you are using a custom theme,
read the instructions here.
The extension comes with 2 design packages: /base/default/ and /rwd/default/ .
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In case you are using a custom theme, it is recommended to copy the design files to your current theme's

folders. In case there are several themes in use at the same store, the design files must be copied to

each of them.

e Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to

/app/design/frontend/[your_package]/[your_theme]/

e Find this folder in the package: /step_ 1/skin/frontend/base/default/ ; copy its content to

/skin/frontend/[your_package]/[your_theme]/

7. Copy the content of /Step_2/ folder to your store's root directory

8. Flush store cache again; log out from the backend and log in again.

Set up cron

The extension uses cron to process expired gift cards.

Generally it would be enough to run in SSH console of your server:
crontab -e
And insert the following line:
*¥/3 * * * * wget -0 - -q 'http://your-store.com/cron.php'

Don't forget to confirm saving request when exit.

Once cronjob is set up and running, the extension will be saving every action in the log, which can be viewed in System-
>Configuration->aheadWorks Extensions->Info->aheadWorks Extensions logging->View log. If you think that the
extension does not work as expected, it is recommended to check the log first. If it is empty or contains very few records,
it may indicate that your cronjob is not set or set improperly. Normally, every cron launch should add 1 or more entries.
Actual quantity of the entries depends on the number of processed events per given cronjob.

Zero Checkout

Providing you want to let your customers to checkout solely

with gift card balance (paying for the whole order with the gift Tite

Mo Payment Information Required

card) the Zero Subtotal Checkout should be enabled. Enanles

Yes

New Order Status

To enable Zero Subtotal Checkout navigate to your
Magento backend System > Configuration > Sales>
Payment Methods > Zero Subtotal Checkout and set
'Enabled’ field to 'Yes'.

Payment from Applicable
Countries

Payment from Specific Countries

Pending

All Allowed Countries

Afghanistan

L L Lo

L

Now your customer can checkout with the gift card balance
solely.

Migrating from Gift Card/Certificate 1.0

The migration tool has been introduced in Gift Card/Certificate version 2.0.2.
1. In the browser window type and run:

your_store.com/shell/giftcard2_update.php

2. Check the results at the store FTP:
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var/log/giftcard2_migration.log

The migration is now complete. If you have any questions - contact our help desk team.

How does it work?

1) Gift Card 2.x branch does not have code scheduling functionality yet;

All the gift codes, that were scheduled to be sent to the recepient on the moment of migration will be postponed after the
migration. Meaning that the store administrator will have to send the codes manually.

2) The status of the 1.x branch gift codes will be migrated along with the codes;

3) The migrated gift codes will have 'Do not send' template assigned to them by default. This comes from the template
difference in the Gift Card/Certificate branches.

Please note, new Gift Card products should be created for Gift Card 2.

Getting Around

Gift Card extension comes ready for work right after installation.

Once installed Gift Card extension introduces its menus under 'Catalog' section of your Magento store (Catalog > Gift
Card by aheadWorks) and 'Configuration' page (System > Configuration > aheadWorks extensions > Gift Card).

We suggest starting with the Gift Card Products section:

Gift Card Products
Choose Store View: | All Store Views j )
Page 1 of 1pages | View (20 || perpage | Total 0 records found | ||
Select All | Unszelect All | Select Visible | Unselect Visible | 0 items selected Actions ﬂ:
Status T  Visibility Thumbnail Hame SKU Type Purchased Gty Used Gty Purchased Amount Used Amount
Any = | =] hd x| From: From: From: From:
To: To: To: To:
in: |[USD = In: |USD =

Catalog > Gift Card by aheadWorks > Gift Card Products

Creating a Gift Card product

Welcome to the Gift Card Products section, this is where you create, manage and set up the Gift Card products. The
process behind creating the Gift Card products is similar to that of native Magento product types with the exception of
Gift Card Information section introduced by the extension. Gift Card Information is a set of options that define the Gift
Card product feel and functionality.

Let's create your first Gift Card product:

1. Start creating a Gift Card product by clicking| w | button;

2. Configure all the settings familiar from creating Magento products: product name, stock quantity etc.; using your
store owner expertise;

3. Click 'Gift Card Information’ to get to the Gift Card product's options when done with general product settings;

4. Configure all the required settings by the setting name (if you are feeling lost - refer to the Gift Card product
settings);
For the demonstration purposes let's configure a virtual Gift Card product, that allows gift message, with open
amount ranging from 501 to 1000 of the base currency.
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5. Click : button once done with the 'Gift Card Information'.
That's it. You have just created your first Gift Card product.

Creating Gift Card codes

In addition to the Gift Card products the extension allows creating Gift Card codes directly. The Gift Card codes can prove
interesting to the store owners who are planning on running physical gift card campaigns or giveaways.

Navigate to the 'Gift Card Codes' section:

Gift Card Codes L_

age 1 of 1 pages | View |20 j per page | Total 1 records found
select Visible | 0items selected Actions j :

Created At L Order Product Type Code Initial Amount Availability Is Used Balance Expiration Daj
Any =| From: ] | From: d x| From: From: 7]
To: [H To: To: To: [H

| Mar 10, 2016 Virual 1CQFJRESAPVK $100.00 Active Mo $100.00 Jun 18, 2016

Catalog > Gift Card by aheadWorks > Gift Card Codes

Welcome to the Gift Card Codes section, this is where you create Gift Card codes and manage the gift cards purchased
by your customers. This screen is a management center of the extension, whether you want to create a Gift Card code,
look for specific code customer may have questions on, or check how well your gift card campaign does - this is a screen
to refer to.

Creating a Gift Card codes is somewhat similar to creating a Gift Card product. There are no native Magento
configuration options to set and all the settings available should be familiar by now.

Let's create a Gift Card code:

1. Start creating a Gift Card code by clicking | © Add Gifi Card Code | button;

2. Fill in required 'Gift Card Information' and set required 'Sender Details' (if you are feeling lost - refer to the Gift Card
code settings);

3. Fill in required Recipient Details and decide whether you want the Gift Card code emailed to the recipient;

4. Click button once done.
You have just created a Gift Card code.

Now it is high time to get in depth with the extension settings and get to know more about the configuration settings that
will help you running a successful gift card campaign.

Adjusting Gift Card options and settings

Extension settings —
Enabled Yes | [STORE VEW

General settings of the Gift Card extension are applied to all Fe e e

the Gift Card products and codes created by default. These

settings can be overriden on the product or code level

respectively. The settings can be found at System > Notfication Email Sender General Contact Fl  sorevew

Configuration > aheadWorks extensions > Gift Card:

« Enabled - allows enabling/disabling the extension's
output;

« Expires After (days) - defines after how many days
since Gift Card has been purchased/created it will
become inactive;
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* Notification Email Sender - defines the email
address from which all the Gift Card related
notifications will be fired (e.g. Gift Card message).

Gift Card code settings

When creating a Gift Card code store owner is suggested to
configure the following settings:

Gift Card Information:

+ Initial Amount - defines the Gift Card amount equal
to the base store currency that can be spent on the
products available;

+ Expires After, days - defines after how many days
since Gift Card has been purchased/created it will
become inactive (Extension settings value is set by
default);

« Website - defines on what website (if you are using
several) the Gift Card will be available for redeeming.

Sender Details:

« Sender Name - defines what name will be displayed
in the field 'From:' of the notification emails;

+ Sender Email - defines an email address from which
the notification emails will be sent.

Recipient Details:

« Recipient Name - defines the name to address the
Gift Card code recipient;

+ Recipient Email - defines the email address to sent
the Gift Card code to;

« Email Template - defines the notification email
template (the templates are managed under System
> Transactional Emails).

Gift Card product settings

When creating a Gift Card product store owner is suggested
to configure the following settings:

« Card Type - defines the type of the Gift Card product:

» Virtual - the Gift Card code will be emailed to
the customer who purchased the Gift Card
product or to the Gift Card recipient;

» Physical - suggests that the store owner issues
physical gift card for required distribution type
(no email notifications sent);

e Combined - the Gift Card code will be emailed
to the customer who purchased the Gift Card
product or to the Gift Card recipient and
suggests that the store owner will double the
Gift Card code with a physical Gift Card.

« Card Description - allows typing in the Gift Card
product description that will be displayed above the
price block;

« Expires After (days) - defines after how many days
since Gift Card has been purchased/created it will
become inactive (overrides Extension settings value);

¢ Allow Message - allows customers to compose an
email message and type in the Gift Card recipient's

confluence.aheadworks.com/pages/viewpage.action?pageld=23562495

Initial Amount *

Expires After, days

Website *

Recipient Name *
Recipient Email *

Email Template

— Please Select—

Do not send

Gift Card Information

[

Gift Card Information

Card Type

Card Description

Expires After (days)
Allow Message

Email Templates

Amounts

Allow Open Amount

Open Amount Min Value =

Open Amount Max Value *

Wirtual

—

Yes

Store View
Web Site

Yes
[usD]

[UsSD]

Email Template

Amount *

=
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name and email address (the templates are managed
under System > Transactional Emails);

« Email Template - allows defining a notification email
template;

+ Amounts - allows adding/removing the Gift Card
product amounts available for customers to select;

+ Allow Open Amount - defines if customers can
manually enter required Gift Card amount;

+ Open Amount Min/Max Value - defile minimum and
maximum Gift Card value available for customers
(works in conjunction with Allow Open Amount).

Integration with other extensions by aheadWorks

Gift Card/Certificate provides out-of-the-box integration with the following extensions by aheadWorks:

» One Step Checkout - let customers configure the gift card at the checkout.

Uninstallation

1. Disable compilation, in case it is enabled.
2. Login to your FTP, navigate to app/etc/modules/
3. Open the file AW_Giftcard2.xml and change the following line:

from

<active>true</active>

to

<active>false</active>

Now your Magento is unaware of the existence of the extension.

4.Clear the cache under var/cache
5.Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.

6. To clean the database, backup your database and then run the following queries in MySQL:

Click to see how to do this

DROP TABLE IF EXISTS "aw_giftcard2_statistics;

DROP TABLE IF EXISTS "aw_giftcard2_quote ;

DROP TABLE IF EXISTS "aw_giftcard2_product_entity_ templates’;
DROP TABLE IF EXISTS "aw_giftcard2_product_entity_amounts’;
DROP TABLE IF EXISTS "aw_giftcard2_invoice’;

DROP TABLE IF EXISTS "aw_giftcard2_history’;

DROP TABLE IF EXISTS "aw_giftcard2_creditmemo’ ;

DROP TABLE IF EXISTS "aw_giftcard2 ;

UPDATE catalog product_entity SET type_id = 'simple' where type_id = 'aw_giftcard2
DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
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DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_amounts';

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_description’;

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_email_templates’;

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_ open_amount_min';

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_ open_amount_max';

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog product_entity_int WHERE attribute_id = (SELECT attribute_id F
DELETE FROM eav_attribute WHERE attribute code = 'aw_gc2 allow_open_amount';
DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog_product_entity_int WHERE attribute_id = (SELECT attribute_id F
DELETE FROM eav_attribute WHERE attribute code = 'aw_gc2 type';

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog_product_entity_int WHERE attribute_id = (SELECT attribute_id F
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_expire’;

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog_product_entity_int WHERE attribute_id = (SELECT attribute_id F
DELETE FROM eav_attribute WHERE attribute code = 'aw_gc2 config _expire’;

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog_product_entity_int WHERE attribute_id = (SELECT attribute_id F
DELETE FROM eav_attribute WHERE attribute_code = 'aw_gc2_allow_message';;

DELETE FROM catalog_eav_attribute WHERE attribute_id = (SELECT attribute_id FROM e
DELETE FROM catalog_product_entity_varchar WHERE attribute_id = (SELECT attribute_
DELETE FROM eav_attribute WHERE attribute code = 'aw_gc2 email templates';

DELETE FROM core_resource WHERE code = 'aw_giftcard2_setup';

Executing the above queries will remove all the module's DB records, and convert the existent Gift Card products to
Simple items.

Note, if you are using the table with prefixes, you must specify them in all table names.

If you are not sure how to do that or expect any troubles with it, please contact your server administrator regarding the
matter.

If you remove the tables as it is described above, you will need to re-configure the extension after it is re-installed. All
transactions history will be lost as well.

7. If everything works fine, it is safe to delete the files of the extension.

Troubleshooting

After the extension installation the store gives an error, or blank page, or suggests to start Magento installation
procedure.

Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked | get a
blank page, or Access Denied error.

Clear the store cache, browser cookies, logout and login again.
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I've set up everything correctly, inserted the HTML code but there is nothing on that page.

Clear the store cache, clear your browser cache and domain cookies and refresh the page.
My configuration changes do not appear on the store.

Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com
License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt
Contact Us: http://ecommerce.aheadworks.com/contacts/
Copyright © 2019 aheadWorks Co. http://www.aheadworks.com

HpaButca  CTtaHbTe NepBbiMU KOMY MOHPABUTCS 3TO Hwu ogHown

confluence.aheadworks.com/pages/viewpage.action?pageld=23562495

9/9


http://confluence.aheadworks.com/pages/viewpage.action?pageId=23562495
http://ecommerce.aheadworks.com/
http://ecommerce.aheadworks.com/LICENSE-M1.txt
http://ecommerce.aheadworks.com/contacts/
http://www.aheadworks.com/

