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Extension page: http://ecommerce.aheadworks.com/magento-extensions/event-tickets.html

The Event Tickets module is an e-ticketing solution that allows Magento merchants to create an unlimited number of free
or paid events, sell tickets online, and manage attendees.

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

Looking for the same Magento 2 functionality?

Check out our Event Tickets for Magento 2:

Product page
User Guide
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current theme's
folders. In case there are several themes in use at the same store, the design files must be copied to
each of them.

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/
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Set up cron 

The Event Tickets extension uses cron for sending out the notifications and validating the event date. Read the following
instructions on setting cron job for your Magento store: Magento user guide. If you have already configured cron jobs for
your Magento installation then you can skip this step.

Generally it would be enough to run in SSH console of your server: 
crontab -e

And add the following line: 
 

*/3 * * * * wget 'http://your-store/cron.php'

Don't forget to confirm saving request when exit. 
If you are not sure how to do that or experiencing any troubles with it, contact your server administrator or hosting
provider regarding the matter.

Once cronjob is set up and running, the extension will be saving every action in the log, which can be viewed in System-
>Configuration->aheadWorks Extensions->Info->aheadWorks Extensions logging->View log. If you think that the
extension does not work as expected, it is recommended to check the log first. If it is empty or contains very few records,
it may indicate that your cronjob is not set or set improperly. Normally, every cron launch should add 1 or more entries.
Actual quantity of the entries depends on the number of processed events per given cronjob.

 

 

 

Configuration
The extension's General Settings screen is located at System -> Configuration -> aheadWorks Extensions -> Even
Tickets (or, Catalog -> Event Tickets -> Settings ) backend page.

QR Codes section allows adjusting the output Image Size
for the extension-generated codes.

For more information on QR Codes functionality, check this
section.

 

Email Templates section:

Here, you can define the default templates for the
extension's Confirmation Email and Reminder Email.

The templates for both notification types can also be re-
defined for a specific product, in the Edit Product screen.
The selection made there will override the default settings.

 

 

Managing Products
The extension allows managing Event Products through a dedicated backend grid: Catalog -> Event Tickets -> Manage
Products. This grid lists ALL the items which had ever had Event Booking functionality enabled.

Product Setup

Updating from 1.0.x to 1.1 version
If you are using an older version of the extension, make sure to update default Confirmation and Reminder
Emails after the new version is installed.

Two new templates should become availalbe in System -> Transactional Emails grid ("[aW Event Ticket] Ticket
Confirmation [New]" and "[aW Event Ticket] Event Reminder [New]") after the installation is complete; these new
templates contain a number of new variables that were not present in the old versions of the module.

http://merch.docs.magento.com/ce/user_guide/Magento_Community_Edition_User_Guide.html#system-operations/cron.html#kanchor1045
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Event Booking | General Settings | event-ticket-types | Terms & Conditions | Attendees | Summary | Redeem Settings

The extension is configured on per-product basis. The module adds extra options to Simple, Downloadable and Virtual
products. To set up the booking options, navigate to Catalog-> Manage Products-> Edit Product-> Event Booking tab.

 

The available options are as follows:

Event Booking section:

Enable Event Booking = "yes/no" - enables or
disables the booking functionality for the product.

 

 

Event Tickets section:

Through this section, you can set up various ticket types and options.

Title - specify the title text for the ticket type selection section in the frontend product view
Ticket Types - you can create a number of different ticket types for the same event. The available tickets may
differ in price.  
*NOTE: at least one ticket type must be created for a product 
A given ticket type has the below options: 

 Title - frontend ticket type title
 Price - the price modifier value

General Settings section:

Date & Time of Event* - here, you should specify the event date. 
* please, note that the extension only allows to assign a single date for an event product. If you are to run several
events, you need to created a product for each.

Send Reminder Message Before, days - if any value is set here, and email reminder will be sent to all the
attendees X days before the event.
Email Template for Reminder Message - here you can choose the email template for the reminder message.
This option overrides the default value set in Catalog -> Event Tickets -> Settings
Generate PDF Tickets (Yes / No) - enables / disables .PDF tickets creation.  
If this option is enabled, the extension will generate a separate printable document for each of tickets sold. These
.PDF files will be attached to the Confirmation Email. 

 
Event Location - here, you can specify the location details.  
Note: the extension supports HTML code for the "Location" field

If you are creating a new product, the Event Booking tab will appear after a product is saved.

How does .PDF tickets generation work?
The Event Tickets extension relies on an external library (TCPDF) for rendering the .PDF tickets. This
library comes included in the module's package and is automatically installed together with the
extension; you can learn details regarding this piece of software here.

To change the appearance of the printable tickets, you will need to edit the following template:

/app/design/frontend/[your_package]/[your_theme]/template/aw_eventbooking/ticket/html.phtml

http://www.tcpdf.org/
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 Price Type - the price modifier type (fixed/ percent) NOTE: the price modifier is added to the basic product
price
 SKU [optional] - allows to add the SKU postfix to the main product's SKU (this postfix will be displayed in
the Order Details). NOTE: creating a separate product is not required.
 Qty - the available quantity of tickets of a given type
 Code Prefix - allows specifying Prefix for the Redeem Code
 Confirmation Email - the email template sent to customer on ordering the ticket of the specific type. This
option overrides the default value set in Catalog -> Event Tickets -> Settings
 Sort Order - setting this option allows to arrange the ticket types list in the preferred order

 

Terms & Conditions section:

Enable Terms & Conditions = Yes/No - This option
enables/disables the Terms And Conditions block. If
enabled, the agreement terms will be displayed on the final
step of the checkout. 
Choose Terms & Conditions - in this selector, you can
choose any of the existent Conditions blocks 

The details on how to enable and add the Terms And
Conditions on your store can be found on Magento
Commerce 

 

 

The next 2 sections show the booking details for the event:

Attendees section:

In this tab, all the event attendees will be listed. Please, note that a customer will appear in this section after their order
gets processed. 
The details from this tab can be exported to a .csv/.xml file. 
You can also send a message to any of the listed attendees directly from this tab - if you apply "Send Message" action, a
pop-up window with simple message editor will open.

 

Summary section:

Shows totals for all the event-related orders.

 

Redeem Settings section:

Through this section, you can select the Admin roles who
can redeem tickets for a particular event.

 

http://www.magentocommerce.com/knowledge-base/entry/setting-up-the-terms-and-conditions-of-a-sale
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The link to a dedicated Redeem Ticket page can be found in
this section as well.

 

 

Managing Tickets
The Catalog -> Event Tickets -> Manage Tickets grid displays the actual ticket sales. The grid is filtered according to
the Admin Roles which have the permission to Redeem Tickets for a particular event.

 

Redeeming Tickets

During the ticket verification phase, a person responsible for tracking the admission is to check if a visitor is eligible for
attending. Since the exact procedure may vary, the extension offers a number of ways to verify the ticket.

 

1. Via scanning a QR code  
The Event Tickets extension comprises QR Codes functionality. It allows redeeming the sold tickets via scanning
an auto-generated QR image. 
This functionality is only available if .PDF tickets generation is enabled. The extension will append a QR code to
every ticket instance. 
 

Cancelling tickets
"Manage Tickets" grid allows cancelling tickets. However, this action does not initiate refund for the order item(s).
If required, the refund must be issued manually.

And vice verse, refunding an order does not cancel associated ticket(s), they can still be redeemed. If the tickets
are to be voided, it must be done manually as well.

To use the extension's automated verification means, the administrator must:

1. Carry any mobile device with any QR Codes scanning app installed (for redeeming via QR codes) OR any
other device with the ability to access Magento backend (for manual verification)

2. Have Internet connection
3. Be logged in to the Magento Admin panel AND have sufficient permissions to redeem the tickets

If for any reason the internet connection is not available, it is possible to print out the attendees list from the
product details screen.

Redeeming tickets via QR codes will only work if the admin user meets the above criteria. If the code is
scanned by a non-authorized person (a logged in customer, a guest or an admin user with insufficient
permissions), a different page will open: it will display the ticket details WITHOUT the actual "Redeem"
option.
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2. Via Ticket Code 
Another method of redeeming a ticket is manual Ticket Code input. The extension generates a unique alpha-
numerical code for each ticket instance (with an option for store admin to specify the code prefix per ticket type).
Those codes are listed in .PDF tickets and in frontend Customer Account area. 
 
A ticket code can be verified from from a dedicated  backend page (the link is provided in the Product Details page
of an event). 
The page contains a simple code input field. After submitting a code, an admin user will see the ticket info page
with an option to cancel. 

 
 

3. Via grid action  
It is also possible to change the ticket status directly from Catalog -> Event Tickets -> Manage Tickets backend
grid.  

 

 

 

Email Templates
The extension uses the email templates from System->Transactional Emails

After the installation, the module adds 2 pre-defined templates ( "[aW Event Ticket] Ticket Confirmation" and "[aW Event
Ticket] Event Reminder" ), but you can use any existent Transactional Email template with the module.

The extension supports standard transactional email variables, along with the below special ones:
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Variable Code DescriptionVariable Code Description

{{var customer_name}} shows the First name of the customer

{{var event_start_date}} , {{var event_date}} display the Start Date of the event

{{var event_end_date}} shows End Date for the event

{{var event.location}} pulls the Location details

{{var event_ticket.title}} shows Ticket Type title

{{var
event.day_count_before_send_reminder_letter}}

shows the value of days specified in Send Reminder Message
Before filed for the product

 

Uninstallation
If you just need to temporary disable the extension, you can just do the steps 1-5, without deleting the files of the
extension.

1. Disable compilation, in case it is enabled.
2. Login to your FTP, navigate to app/etc/modules/
3. Open the file AW_Eventbooking.xml and change the following line:

to 

Now your Magento is unaware of the existence of this module.
4. Clear the cache under var/cache
5. Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
6. If everything works fine, it is safe to delete the files of the extension.
7. In case you need to clean the database, backup your database and then run the following queries in MySQL:  

 

Note, if you are using the table with prefixes, you must specify them in all table names. 

If you are not sure how to do that or expect any troubles with it, please contact your server administrator regarding
the matter. 
If you remove the tables as it is described above, you will need to set up all the event products after the extension
is reinstalled. All reservations history will be lost as well.

<active>true</active>

<active>false</active>

DROP TABLE IF EXISTS `aw_eventbooking_event_attribute`;
DROP TABLE IF EXISTS `aw_eventbooking_event_ticket_attribute`;
DROP TABLE IF EXISTS `aw_eventbooking_order_history`;
DROP TABLE IF EXISTS `aw_eventbooking_event_ticket`;
DROP TABLE IF EXISTS `aw_eventbooking_event`;

delete from `core_resource` where `code` = 'aw_eventbooking_setup'; 

http://ecommerce.aheadworks.com/contacts/
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Нравится Станьте первыми кому понравится это

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento installation
procedure.

    Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear the
store cache and try again.

After the extension installation I receive 404 error in System->Configuration->Points & Rewards.

    Logout from backend and login back again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get a
blank page, or Access Denied error.

    Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing on that page.

    Clear the store cache, clear your browser cache and domain cookies and refresh the page.

My configuration changes do not appear on the store.

    Clear the store cache, clear your browser cache and domain cookies and refresh the page.

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2019 aheadWorks http://www.aheadworks.com
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