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Extension page: http://ecommerce.aheadworks.com/magento-extensions/automatic-related-products-2.html

Automatic Related Products 2 is extremely flexible extension which allows you to forget about outdated way of adding
related products. Define the rules for products selection and let this software populate the block automatically! 

 

Installation

1. Backup your web directory and store database.
Click to view details
You can make backup copies with any tool you find appropriate

If you are going to use the native Magento backup function, navigate to System -> Tools -> Backups and
perform System and Database backups

 2. Log in to the Magento backend

 3. Disable compilation
Click to view details
Navigate to System -> Tools -> Compilation.

If Compiler status is Disabled, you can skip to the next step

If Compiler is enabled, disable it.

Having hard time finding
an answer to your
question?

Check out our
Knowledge Base.

Automatic Related Products 2.0 is not compatible with the previous extension versions, so if you have Automatic
Related Products 1.X, you need to uninstall it.

http://confluence.aheadworks.com/display/EUDOC
http://confluence.aheadworks.com/display/EUDOC/Documentation+Home
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http://ecommerce.aheadworks.com/magento-extensions/automatic-related-products-2.html
http://ecommerce.aheadworks.com/kbase/extension-automatic-related-products-2/
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IMPORTANT: after the extension is installed, you can enable the compilation again; IT IS CRUCIAL that you use
"Run Compilation Process" function, not just "Enable button"

 4. Flush store cache
Click to view details
You can flush the store cache in 2 ways:

via the backend:

Navigate to System -> Cache Management menu, and click Flush Magento Cache button

via filesystem:

On your server, navigate to Magento root folder, then proceed to /var/cache/; delete all the content there.

 5. Download the extension package from your account and extract the downloaded archive

 6. Copy the content of /Step_1/ folder to your store's root directory

Installing an extension with the Compilation enabled will result in store downtime.

If you are using a custom theme,
read the instructions here.
In case you are using a custom theme, it is recommended to copy the design files to your current theme's
folders. In case there are several themes in use at the same store, the design files must be copied to
each of them.

Find this folder in the package: /step_1/app/design/frontend/base/default/ ; copy its content to
/app/design/frontend/[your_package]/[your_theme]/
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 7. Copy the content of /Step_2/ folder to your store's root directory

 8. Flush store cache again; log out from the backend and log in again.

 

Configuration
Extension's general configuration section (located at Catalog -> Automatic Related Products -> Configuration, or
System -> Configuration -> aheadWorks Extensions -> Automatic Related Product) serves mostly for convenience,
and has only one option.

Number of products - defines the default number of
items to be displayed in a block. This setting can be
overridden in the configuration of each block;

 

You can manage the existent blocks and create new ones via Catalog -> Automatic Related Products -> Manage
Blocks backend page. A new block can also be created from Catalog -> Automatic Related Products -> Add Block.

Creating a New Block

After initializing new block creation, the first step is to define the block type.

There are 3 available types:

Product Page Block;
Category Page Block;
Shopping Cart Block.

Each of these type have different set of configuration options
and available block positions.

 

General Block Settings

 

In General tab, you can define the basic block parameters. The
options listed in this tab are common for all the 3 block types:

Block Name - will be used as the block title in the frontend;
Status - enables / disables the block;

Find this folder in the package: /step_1/skin/frontend/base/default/ ; copy its content to
/skin/frontend/[your_package]/[your_theme]/

The main configuration of the Automatic Related Products 2 extension is done on per-instance basis. I.e., each of
the module's blocks can have its own setup.

Note, the block type can only be selected during this
step, it can not be changed for a given block later
on.
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Store view - allows selecting what storeview(s) the block
will appear on;
Customer Groups - allows restricting the Customer Groups
the block will be shown to;
Priority - sets the block priority. In case there are several
blocks to be rendered in the same page in the same
positions, the one with lower priority value will be displayed
on top;
Date From-To - sets the time period the block will be active
through;
Position - in this selector, you can choose either one of the
pre-defined positions* or Custom one. In the latter case, you
will need to insert the block manually.

 

 

Category Block settings

In the "Currently Viewed Category" tab, you can choose on
what category pages the block will be displayed.

If All is selected, the block will be shown in every
store category;
If Custom is selected, you will need to tick the
necessary categories in the below tree selector.

In the "Related Products" tab, you can create a rule
defining what products will be shown in the block.

General section:

*Note: the available pre-defined positions depend on the
selected block type.

See details
Here's the breakdown on the available block positions

Block
Position

Product
Page
Block

Category
Block

Shopping
Cart
Block

Before
Content

+ + +

Instead
Native
Related
Block

+ - -

Under
Native
Related
Block

+ - -

Inside
Product
Page

+ - -

Replace
Cross-
Sells
Block

- - +

Custom + + +
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Include - this option defines where the related items
will be taken from. The available values are:

All;
Current Category Only;
Current category and its subcategories;

Number of products - defines the number of items
displayed in the block;
Order Products - defines how the related items will
be sorted:

None - the products will be ordered by their ID;
Random - the product set will be randomized;
By Attribute - the products will be sorted by an
attribute*; 
*If "By Attribute" option is selected, 2 new
options will get displayed: Attribute Selector
and Sort Direction (Ascending / Descending).

Show "Out of stock" Products - defines if "Out of
stock" items will be shown in the block

 

Conditions section:

In this section, you can set the additional filtering on the
products to display. The available conditions are based on
product attributes.

E.g., you can set the extension to show only products with
Price of $100 and higher

 

Product Block settings

In the "Currently Viewed Product" tab, you can choose on
what product pages the block will be displayed.

E.g., you can make the block appear only for the products
that have "phone" or "tablet" in their names

In the "Related Products" tab, you can define the items that will be related to current product.

General section:

Here, you are to define the basic criteria for establishing the
product relations. You should select a target product attribute
and the match condition (equals, less / greater, etc).

Note, the attributes are always matched against the currently
viewed product.

You can add multiple rows in this section, the resulting
product collection will include items that meet ALL the
specified conditions.

The collection can be further filtered via the conditions set in
the section below.

 

 

Conditions section:

To make a product attribute available for Automatic
Related Products 2 rules, select Yes in the "Use
for Promo Rule Conditions" field in the attribute
properties.



22.04.2019 Automatic Related Products 2 - Documentation - Confluence

confluence.aheadworks.com/display/EUDOC/Automatic+Related+Products+2 6/10

In this section, you can set the additional filtering on the
products to display. The available conditions are based on
product attributes.

E.g., you can set the extension to show only products which
have been added to the catalog on Mar, 09th, 2104

 Other section:

Number of products - defines the number of items
displayed in the block;
Order Products - defines how the related items will
be sorted:

None - the products will be ordered by their
ID;
Random - the product set will be randomized;
By Attribute - the products will be sorted by
an attribute*; 
*If "By Attribute" option is selected, 2 new
options will get displayed: Attribute Selector
and Sort Direction (Ascending / Descending).

Show "Out of stock" Products - defines if "Out of
stock" items will be shown in the block

Shopping Cart Block settings

 

In the "Shopping Cart Conditions" tab, you can define
conditions under which the block will be displayed. The
available conditions are based on Shopping Cart
attributes.

E.g., you can make the block appear only if a customer has
5 or less items in their cart

 

In the "Related Products" tab, you can define the items that will be related to shopping cart items.

General section:

Here, you can define the actual criteria for the item
suggestions.

The criteria set here will be matched against all the items
currently found in the cart.

The item will be shown as a related products in case all of
the conditions match those of ANY item in the current cart.

Conditions section:

In this section, you can set the additional filtering on the
products to display. The available conditions are based on
product attributes.

E.g., you can set the extension to show only products with
Price of $50 and higher

 Other section:

Number of products - defines the number of items
displayed in the block;
Order Products - defines how the related items will
be sorted:

None - the products will be ordered by their ID;
Random - the product set will be randomized;
By Attribute - the products will be sorted by an
attribute*; 
*If "By Attribute" option is selected, 2 new
options will get displayed: Attribute Selector
and Sort Direction (Ascending / Descending).
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Show "Out of stock" Products - defines if "Out of
stock" items will be shown in the block

 

Custom Block Position

CMS and Widget

If Custom position has been selected for a block, the latter must be inserted via CMS or widget. Go to static block or CMS
page you want related products to be displayed on and insert block as widget or put the following text into the content
field.

 

For product block:
 

 

For category block:
 

 

For shopping cart block:

 

Where:

block_id - the ID of the block that will be inserted
product_id - the ID of the target product
category_id - the ID of the target category

Define the product_id (for product block) and category_id (for category block) while inserting the block via CMS or widget.
Otherwise, the block will get the id of the current page.

 

{{block type="awautorelated/blocks" product_id="product/1" block_id="8"}}

{{block type="awautorelated/blocks" block_id="8" category_id="category/3"}}

{{block type="awautorelated/blocks" block_id="8"}}

For Automatic Related Products v. 2.4.5 and below
If you are inserting an ARP 2 block into a CMS static page, you may need to add the below layout update (CMS
page -> Design -> Layout Update XML) in case the styles are not initialized properly.

<reference name="head">
 
           <action method="addCss">
 
                <stylesheet>aw_autorelated/css/product.css</stylesheet>
 
           </action>
 
           <action method="addCss">
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Updating view.phtml

Depending on the Automatic Related Products block type (Product Page, Category Page, Shopping Cart) it is possible to
replace native Magento related and cross-sells blocks.

However, when it comes to for example up-sells it is required to either disable native Magento up-sells and place
Automatic Related Products block via CMS or widget, or update view.phtml.

In this example we will place the Automatic Related Products block instead of native Magento up-sells block.

Navigate to your store FTP:

app/design/frontend/your_theme/your_package/template/catalog/product/view.phtml

Find the line:

And use the following code to either replace up-sells code or paste it in a position required:

Where:

block_id - is the ID of the Automatic Related Products block you want to display.

                <stylesheet>aw_autorelated/css/shoppingcart.css</stylesheet>
 
           </action>
 
</reference>

<?php echo $this->getChildHtml('upsell_products') ?>

<?php echo $this->getLayout()->createBlock('awautorelated/blocks')->setBlockId(block_id)->t

Where to find the block ID
Automatic Related Products block ID can be found under Cataglog > Automatic Related Products >
Manage Blocks:

Please note, when updating view.phtml depending on the theme peculiarities layout adjustments may be
required to display Automatic Related Products block properly.
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Integration with other aheadWorks extensions
The Automatic Related Products 2 extension is integrated with several other aheadWorks products:

Follow Up Email (since v.3.5) - the Automatic Related Products 2 blocks can be used for item suggestions in
outgoing Follow Up Email messages
One Step Checkout - Automatic Related Products 2 blocks can be rendered in the Checkout screen

 

Uninstallation 
1. Disable compilation, in case it is enabled.
2. Login to your FTP, navigate to app/etc/modules/
3. Open the file AW_Autorelated.xml and change the following line: 

4. Clear the cache under var/cache
5. Make sure that the site is working properly, otherwise roll back the changes and apply to our technical support.
6. If everything works fine, it is safe to delete the files of the extension.

Troubleshooting
After the extension installation the store gives an error, or blank page, or suggests to start Magento installation
procedure.

         Change the owner of the extracted extension files to the web server user and set 775 permissions on them. Clear
the store cache and try again.

There is no aheadWorks extensions under my configuration section, or having the extension tab clicked I get a
blank page, or Access Denied error.

         Clear the store cache, browser cookies, logout and login again.

I've set up everything correctly, inserted the HTML code but there is nothing on that page.

         Clear the store cache, clear your browser cache and domain cookies and refresh the page.

My configuration changes do not appear on the store.

           Clear the store cache, clear your browser cache and domain cookies and refresh the page.

Some of my product attributes are missing in the block settings.

           Make sure to enable the "Use For Promo Rule Conditions" option in the attribute properties. See details here. 

 

You can always find the latest version of the software, full documentation, demos, screenshots and reviews
at http://ecommerce.aheadworks.com 

License agreement: http://ecommerce.aheadworks.com/LICENSE-M1.txt 
Contact us: http://ecommerce.aheadworks.com/contacts/ 

Copyright © 2019 aheadWorks Co. http://www.aheadworks.com

 

 

to

<active>true</active>

<active>false</active>

https://ecommerce.aheadworks.com/magento-extensions/follow-up-email.html
http://ecommerce.aheadworks.com/magento-extensions/one-step-checkout.html
http://ecommerce.aheadworks.com/contacts/
https://ecommerce.aheadworks.com/kbase/extension-automatic-related-products-2/product-attribute-is-missing-in-block-settings.html
http://ecommerce.aheadworks.com/
http://ecommerce.aheadworks.com/LICENSE-M1.txt
http://ecommerce.aheadworks.com/contacts/
http://www.aheadworks.com/
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Нравится Станьте первыми кому понравится это Ни одной
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